WordPress предупредит об использовании устаревших версий PHP

К декабрю 2019 года PHP 7.0 станет минимальной версией PHP, необходимой для работы сайтов на WordPress.

Система управления контентом WordPress начнет отображать на админпанели предупреждения об использовании устаревших версий PHP (версии PHP до 5.6.х). Нововведение появится в версии WordPress 5.1, запланированной к выпуску весной текущего года, пишет ZDNet.

Уведомление будет содержать ссылку на страницу поддержки WordPress с информацией о том, как владельцы сайтов могут обновить используемую версию PHP.

Решение о показе предупреждений было принято в декабре 2018 года после выпуска версии WordPress 5.0. Как показывает статистика, 85% владельцев сайтов на WordPress 5.0 используют версии PHP 5.6 и выше, поэтому уведомление будут отображаться только для небольшой группы пользователей.

На сегодняшний день на устаревших версиях WordPress работают миллионы сайтов, многие из них заброшены.

Краткосрочная задача заключается в том, чтобы перевести как можно больше пользователей на более новые версии PHP. Это позволит разработчикам WordPress полностью отказаться от поддержки старых версий PHP. К апрелю 2019 года команда намерена официально изменить минимальные требования с PHP 5.2 (на данный момент) на PHP 5.6. Аналогичная мера запланирована для MySQL — новым минимальным требованием станет использование MySQL 5.5.

К декабрю 2019 года PHP 7.0 станет минимальной версией PHP, необходимой для работы сайтов на WordPress.

WordPress — система управления содержимым сайта со свободным пограммным обеспечением, написанная на PHP. Использует сервер базы данных MySQL. Сфера ее применения — от блогов до сложных новостных ресурсов и интернет-магазинов.

Источник: securitylab.ru

Вы можете оставить комментарий, или ссылку на Ваш сайт.


Оставить комментарий

Вы должны войти, чтобы иметь возможность оставлять комментарии.